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Simulink Integration: Simplified workflows for importing lookup tables
and features and exporting data dictionaries
Model-Based Calibration Toolbox now includes these simplified workflows for importing lookup tables
from Simulink® models into CAGE and exporting data dictionaries.

Goal Using Workflow
Fill Simulink
lookup tables and
export data to
Simulink model
workspace.

Statistical models
or optimization
results

1 In the CAGE browser, select Simulink Lookup Tables.

Select the Simulink model.
2 Use the MBC Simulink Lookup Table Importer to preview and

import all lookup tables in a subsystem. Click Import Tables to
import tables into CAGE.

3 In CAGE, fill the lookup tables using statistical models or
optimization results.

4 To export the calibration to a Simulink model workspace or data
dictionary, select File > Export > Calibration. Set Export to to
Simulink Data.

For more information, see “Import Lookup Tables from a Simulink
Model”.

R2020a

1-2



Goal Using Workflow
Feature calibration 1 In the CAGE browser, select Feature Filling.

Select the Simulink model.
2 Use the MBC Feature Importer to preview tables and import the

features for the selected subsystems. Click OK.
3 In CAGE, fill the lookup tables using feature fill.
4 To export the calibration to a Simulink model workspace or data

dictionary, select File > Export > Calibration. Set Export to to
Simulink Data.

For more information, see “Set Up Feature and Strategy” and
“Calibrate a Feature for an Estimator Subsystem in an ECU”.

Compatibility Considerations
In R2020a, to export a calibration to a Simulink model workspace from CAGE, select File > Export >
Calibration and set Export to to Simulink Data. This replaces the Simulink Model Workspace
parameter setting for Export to.
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Optimization Progress: View result surface tables during optimization
The Optimization Progress dialog box provides the status of the optimization in progress, including
the results surface tables.

Optimization Objective Progress Dialog Box
Point

The dialog box provides the
number of completed and
acceptable operating point
solutions. You can change the
axes to view a specific result
surface as the optimization runs.

R2019b
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Optimization Objective Progress Dialog Box
Sum

In the dialog box, the trace lines
provide this additional
optimization information.

Trace Color Description
Black Objective
Red Maximum

constraint
violation

You can change the axes to view
a specific result surface as the
optimization runs.

Performance: Improved optimization performance with default
settings and algorithms
To improve optimization performance, R2019b includes these updates.
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Update
Default settings Default settings for these optimization algorithms.

• fmincon
• modal
• GA
• patternsearch
• gamultiobj
• NBI
• paretosearch
• multistart
Default algorithms for point and sum optimizations.

• sqp algorithm for point optimizations
• interior-point algorithm for sum optimizations

R2019b
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Update
Setting for sum optimizations that use the fmincon algorithm. By default, the
optimization option Make table gradient constraints feasible is enabled.

Model-Based Calibration Toolbox tries to satisfy the table gradient constraints before the
fmincon algorithm begins optimizing. For more information, see Edit Optimization
Parameters.

Model-Based Calibration Toolbox sets advanced optimization options that depend on the number of
optimization variables and constraints.

Optimization Solutions: Use soft constraints to find feasible
optimization solutions
When you specify a soft constraint, Model-Based Calibration Toolbox does not require that the
optimization satisfies the constraint. Instead, Model-Based Calibration Toolbox allows for some slack
around the constraint. During the optimization, the algorithm satisfies the soft constraint by
minimizing the slack and optimizing the objective. Consider specifying soft constraints when the:

• Constraint bounds are not well understood.
• Optimization has difficulty finding feasible solutions with hard constraints.

To specify a soft constraint, in CAGE, on the Constraints pane, select Soft Constraint.
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For more information about using soft constraints, see Soft Constraints.

Optimization Tradeoffs: Simplified workflow for viewing and assessing
optimization tradeoffs
R2019b simplifies viewing and assessing optimization tradeoffs in the CAGE browser. For more
information, see Tradeoff Calibration.

Initialization

You can initialize the entire tradeoff to set the tradeoff points for all operating points. In the CAGE
tradeoffs view, after you select a tradeoff table, use these settings.

Goal Option
Set all tradeoff points to
the table values

Inputs > Initialize from Tables

Set all tradeoff points to
the optimization solution

Either:

• In the toolbar, select Inputs > Initialize from Optimization
• In the right-hand pane, select Initialize

In the optimization view, you can select Fill Tables.
Clear tradeoff points Inputs > Clear tradeoff

Navigation

In CAGE, you can navigate between the tradeoff plots and the optimization results.

R2019b
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Goal Option
Navigate from
optimization results to
tradeoff plots.

In the Common Tasks, select Tradeoff.

Navigate from tradeoff
plots to optimization
results.

In the right-hand-pane, select Open.

Tradeoff Plot View

The Tradeoff plot views include optimization information that allows you to quickly assess results.
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Enhancement Description
Optimization
summary

You can select an optimization for comparison with the current table values.

Goal Option
Open the optimization results Open
Set the initial values to the table values
and rerun the optimization

Run

Set all tradeoff points to the optimization
solution

Initialize

• For single objective optimizations, the view includes a summary of constraints
evaluated at the lookup table values for the current operating point.

• For modal optimizations, you can select the mode.
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Enhancement Description

• For multiobjective optimizations, the view includes the Pareto view. The blue start
indicates the optimization result.

R2019b
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Enhancement Description
Lines for tradeoff
points, table values,
and optimization

The plots show lines for the tradeoff points, table values, and optimization. You can
double-click on the lines to set the tables and tradeoff.

• Double-click the orange line to update tables to the tradeoff values.
• Double-click the blue line to set the tradeoff value to the optimization solution at

that operating point.
• Double-click the purple line to set the tradeoff value to the table value at that

operating point.
Tradeoff plot legend The plots include tradeoff points, boundaries, responses, and values. For colors, refer to

the legend.
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Enhancement Description
Lookup table surface
view

The surface table view uses white dots to indicate the tradeoff points. You can select
the white dots to change the table operating point. Right-click the table surface to edit
or print to a figure.

R2019b
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Optimization: Simplified workflow for assessing results, including
lookup table comparison
R2019a simplifies viewing and assessing optimization results in the CAGE browser. New capabilities
include:

• Default configurations for single-objective, multiobjective, and modal optimizations that make it
easier to assess optimization results.

Optimization Default View
Single objective

R2019a
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Optimization Default View
Multiobjective
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Optimization Default View
Modal

• A Current Result Evaluation toggle button that you can use to view the optimized solution or
lookup table values for the current result.

R2019a

3-4



For more information about analyzing optimization results, see Optimization Analysis.

Additionally, if you have Global Optimization Toolbox, you can use the Pareto search algorithm for
multiobjective optimizations.

Automate Model Fits: Generate a MATLAB function that fits models
with new data
You can generate a MATLAB® function that creates a new test plan from an existing test plan. The
test plan contains the same data pre-processing rules, model types, and boundary models that are in
the original test plan. Use the function to fit a model with new data.

To generate the function:

1 Select the model node.
2 Select TestPlan > Generate Code
3 Name and save the function.

For more information, see Automate Model Fits with MATLAB Function.

Gaussian Process Models: Quickly Assess Box-Cox Transformations
For Gaussian process models (GPMs), you can use the Box-Cox Transformation dialog box to adjust
the transformation. In the Model Browser, select the model. To open the dialog box, select Model >
Box-Cox Transform. Previously, you could only use the Box-Cox Transformation dialog box to adjust
the transformation for linear models.

For more information, see Box-Cox Transformation.

 

3-5

https://www.mathworks.com/help/releases/R2019a/mbc/optimization-analysis.html
https://www.mathworks.com/help/releases/R2019a/mbc/model/edit-test-plan-definition.html#mw_4aed8842-a730-43c9-a82b-eaaaf4e39da3
https://www.mathworks.com/help/releases/R2019a/mbc/model/box-cox-transformation.html


Data and Model Fit APIs: Additional support for importing, exporting,
and fitting table data
R2019a introduces command-line APIs and functions for importing, exporting, and fitting table data.

API Enhancement
CreateData Support for tables and structures when importing data to a project.
ImportFromTable

ExportToTable

New mbcmodel.data methods for importing and exporting tables.

ValidationRMSE New mbcmodel.model method to calculate the root-mean-square
error (RMSE) of a validation set.

fit New mbcmodel.fit function to fit a model to data without creating
a model object. Supports numeric, table, and data objects.

Compatibility Considerations
The fit method replaces Fit. Both methods fit model to data. However, the output order is different.
Existing scripts are not affected.

Function Syntax
fit [model,statistics] = fit(model,X,Y)
Fit [statistics,model] = Fit(model,X,Y)

R2019a
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Classifiers: Represent engine operation boundaries with classification
models, including support vector machines
Using support vector machine (SVM) or discriminant classifiers, Model-Based Calibration Toolbox can
differentiate between good and bad operating conditions when you specify boundary constraints for:

• Design of experiments (DoEs)
• Calibrations

To use SVM or discriminant classifiers for DoE and boundary constraints:

1 Use the Statistics and Machine Learning Toolbox™ to classify data using a discriminant or SVM
classifier. For more information, see Support Vector Machine Classification (Statistics and
Machine Learning Toolbox).

2 Use the Classification Learner App (Statistics and Machine Learning Toolbox) to export the
classification model to the workspace.

To
Use the SVM
classification
model as a
DoE
constraint

1 In the Model Browser, select TestPlan > Design Experiment to open the Design Editor.
2 In the Design Editor, select Edit > Constraints.
3 In the Constraint Manager, click Import. In the Import Constraints dialog box, set Import

from to Classifiers. Import the SVM classification.

R2018b
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To
Use the SVM
classification
model as a
boundary
constraint
during
calibration

1 In CAGE, select File > Import > Classification Model.
2 In the Import dialog box, click OK to import the SVM classification.

3 In the Import Models dialog box, accept the defaults and click OK.

4 In CAGE, select Optimization > Constraints > Edit Constraint. For the svm input
model:

• Set Evaluate quantity to Boundary constraint.
• Specify the Constraint type and Constraint bound.
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To

Feature Fills: Streamlined setup and validation
To streamline the feature fill setup and validation, the Model-Based Calibration Toolbox provides
these workflow enhancements. For more information, see Feature Calibration.
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Workflo
w Step

Enhancement

Setup
feature
fills

After you import the strategy, the Feature Fill wizard has default settings that allow you
to quickly set up the feature fill.

Feature Fill Wizard
Tables to fill
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Workflo
w Step

Enhancement

Feature Fill Wizard
Feature setup,
including reference,
input data source,
and smoothing factor
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Workflo
w Step

Enhancement

Feature Fill Wizard
Model inputs

Input grid
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Workflo
w Step

Enhancement

Validate
feature
fill

To help assess and validate the feature fill, the CAGE Browser feature view includes these
tabs.

Tab Description
Table Preview —
Preview of table
shape, with filled,
uninitialized, or locked
status

Validation — Validation
plots comparing model
to validation data, with
fit statistics

Response Models: Use parallel processing to fit data with one-stage
and point-by-point models
By default, Model-Based Calibration Toolbox runs one-stage and point-by-point response model fits in
parallel if you have Parallel Computing Toolbox™. Running the response model fits in parallel
significantly reduces the computation time for large data sets.

When you fit the model with the data, Model-Based Calibration Toolbox calls parpool to open the
parallel pool, if necessary. You see progress messages until the fitting completes. For more
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information about parallel processing, see Specify Your Parallel Preferences (Parallel Computing
Toolbox).

Data Outliers: Save time when you remove and restore data outliers
from all response models
After you fit your data with a statistical model, you can quickly remove and restore data outliers from
all response models. In the Model Browser, after you select a response model, select Outliers >
Apply to All Response Models. After you select the option, these actions apply to all response
models:

• Remove Outliers
• Restore Removed Data

Model-Based Calibration Toolbox updates the response and boundary model fits with the updated
data. For more information, see Remove and Restore Outliers.

MATLAB String Support: Functions in Model-Based Calibration Toolbox
accept MATLAB strings as input
You can use MATLAB strings for functions in the Model-Based Calibration Toolboxautomation scripts.
See Automation Scripting. For information on MATLAB strings, see Create String Arrays (MATLAB).
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Calibration Templates: Automatically rerun calibration optimization
and table fills when you update models
To streamline importing models and filling tables during optimization, Model-Based Calibration
Toolbox now provides these workflow enhancements.

Workflow Step Enhancements
Import models • In CAGE, you can start the Import Models wizard using one of these methods:

• Toolbar

• File > Import > Model
• App home

To import projects, select File > Import From Project.
• The Import Models wizard asks you if you want to replace existing models. If

you do replace existing models, Model-Based Calibration Toolbox reruns the
feature fills and optimizations that use the models.

• Streamlined compatible model merge into composite models. During model
import, Model-Based Calibration Toolbox checks to see if response models
with the same name are in more than one test plan. If so, the Import Model
wizard asks if you want to merge compatible models into composite models.

R2018a
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Workflow Step Enhancements
Update tables
with new models

After you import and replace the existing models, the Import Models wizard
starts the Update Tables dialog box. You can use the Update Table dialog box to
rerun optimizations and feature fills to update the tables with the new models.

Fill lookup tables Create Lookup Tables from Model wizard options:

• Optimization/Tradeoff — Fill lookup tables using optimization results.
Model-Based Calibration Toolbox also creates a tradeoff.

• Models — Fill lookup tables using the standard feature fill at the table grid
points, including any boundary model. Model-Based Calibration Toolbox uses
the same feature fill configuration for subsequent table refills.

• None — Create a table without a tradeoff.

Compatibility Considerations
In R2018a, models cannot be exported to an .exm model file. Instead, you can export your model to
Simulink, the Simulink workspace, or CAGE.

Powertrain Blockset Integration: Use measured data to calibrate and
generate tables for Powertrain Blockset mapped engines
You can use measured data to calibrate lookup tables for these Powertrain Blockset™ engine blocks:

• Mapped CI Engine — Implements a mapped compression-ignition (CI) engine model
• Mapped SI Engine — Implements a mapped spark-ignition (SI) engine model

To help you get started with the calibration, the CAGE browser and Model Explorer include these
examples.
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Example Description Lookup Tables
Mapped CI Lookup
Tables as Functions of
Fuel Mass and Engine
Speed

Lookup tables as a function
of fuel mass and engine
speed

• Power
• Air
• Fuel
• Temperature
• Efficiency
• Hydrocarbon (HC) emissions
• Carbon monoxide (CO) emissions
• Nitric oxide and nitrogen dioxide (NOx)

emissions
• Carbon dioxide (CO2) emissions
• Particulate matter (PM) emissions

Mapped CI Lookup
Tables as Functions of
Engine Torque and
Speed

Lookup tables as a function
of engine torque and
engine speed

Mapped SI Lookup
Tables as Functions of
Engine Torque and
Speed

Lookup tables as a function
of engine torque and
engine speed

Simulink Integration: Export lookup tables to the Simulink model
workspace
After you run an optimization and fill the calibration tables, you can export the results to the Simulink
model workspace. You can use the calibration table data in Simulink models. To export the calibration
lookup tables, select File > Export > Calibration > All Items. In the Export Calibration Data dialog
box, for the Export to parameter, select Simulink Model Workspace.

This table summarizes the changes to the Export to parameter settings.

Setting R2018a Change
ATI Vision Removed
ATI Vision MAT file None
INCA DCM file None
Matrix MAT file New —Saves table data as matrices and vectors in a MAT file
Simulink Model Workspace New—Saves table data in Simulink model workspace
Simple CSV file None
Simple MAT file Renamed to Structure MAT file
Structure MAT file Renamed from Simple MAT file
Simple MATLAB file None

Compatibility Considerations
In R2018a, ATI Vision calibration data cannot be imported or exported. Instead, you can import or
export calibration from ATI Vision MAT or INCA DCM files.

Optimization: Streamlined setup and improved modal optimization
To streamline the optimization setup, the Model-Based Calibration Toolbox provides these workflow
enhancements.

R2018a
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Workflow Step Enhancement
Create optimization from
model

The Create Optimization from Model wizard has default settings for
standard optimizations. To open the wizard, in CAGE, use one of these
options:

• Tools > Create Optimization from Model
• File > New > Optimization

If you have a user-defined optimization algorithm with advanced options,
to create the optimization, select File > New > Custom Optimization.
For more information about optimization algorithm advanced options, see
User-Defined Optimizations.

Create constraints The CAGE browser has default constraint settings for standard
optimizations. The Model-Based Calibration Toolbox bases the default
objective and constraint names on the model names. In the Range
Constraint dialog box, you can specify bounds with lookup tables.

To add or edit a constraint, in CAGE, select Optimization > Constraints.
Use sum or point
optimization

To streamline sum and point optimizations, the Model-Based Calibration
Toolbox includes these changes. In CAGE:

• You can convert the optimization to a sum optimization. Select
Optimization > Convert to Sum Optimization. CAGE converts the
objectives to sum objectives.

• You can convert the optimization to a point optimization. Select
Optimization > Convert to Point Optimization.

• If you rerun point optimizations that have associated sum
optimizations, the Model-Based Calibration Toolbox can update and
rerun the sum optimization with the point optimization results. The
Model-Based Calibration Toolbox uses the existing sum optimization
constraints when it reruns the optimization. Previously, the Model-
Based Calibration Toolbox created a new sum optimization.

• For sum optimizations:

• The Number of operating points is the number of points that the
optimizer sums during the optimization.

• Use Select Scalar Variables to specify the scalar values that do
not depend on the operating points.

• For point optimizations, the Number of operating points is the
number of runs.
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Workflow Step Enhancement
Select optimization
options

The CAGE browser has default optimization settings for standard
optimizations. By default, the optimization algorithm is fmincon.

For modal optimizations, the CAGE browser includes multistart options
that help the optimizer find global solutions.

To view the optimization parameters, in CAGE, select Optimization >
Setup. The dialog box lists the most commonly changed parameters first.

Select variables and
algorithms

After you create the optimization, you can change the free variables,
scalar variables, and algorithm. Previously, you could only select the
variables and algorithm when you created the optimization.

To select a variable or algorithm, in CAGE, select either Optimization >
Select Free Variables or Optimization > Select Algorithm.

Compatibility Considerations
In a future release, Model-Based Calibration Toolbox will not run custom optimizations that have
user-defined optimization algorithms with advanced options.

In R2018a, the optimization algorithm foptcon is renamed to fmincon. To streamline the
optimization setup, these Optimization > Setup parameters are removed:

• Minimum change in variables for gradient
• Maximum change in variables for gradient

R2018a
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Model-Based Calibration Toolbox renames optimization scripts that use foptcon to fmincon.

Gaussian Process Model: Improved model fits for large data sets
To fit Gaussian process models (GPMs) for large data sets, Model-Based Calibration Toolbox uses a
limited-memory Broyden-Fletcher-Goldfarb-Shanno (LBFGS) optimization algorithm from the
Statistics and Machine Learning Toolbox. Previously, for large data sets, Model-Based Calibration
Toolbox used the fmincon optimization algorithm. The LBFGS algorithm improves the optimization
performance. For more information about GPMs, see Global Model Class: Gaussian Process Model.
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Getting Started Example: Generate Current Controller Calibration
Tables for Flux-Based Motor Controllers
Use the getting started example to generate optimized calibration tables for flux-based motor
controllers. The example shows how to import data, fit a model, and optimize the data based on
objectives and constraints. See Generate Current Controller Calibration Tables for Flux-Based Motor
Controllers.
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MBC Model Fitting App and MBC Optimization App Home Pages: Get
started or resume work faster by accessing frequent tasks, recent
projects, and featured examples
In the home page, you can get started or resume work faster by accessing common tasks, examples,
and recent projects.

For details, see Set Up Designs and Models, Resume Work, or Find Engine Modeling Examples and
Set Up Calibrations, Resume Work, or Find Calibration Examples.

Compatibility Considerations
The home page offers the same tasks that were previously available in the Common Tasks pane, and
previously you had to search the documentation to find examples.
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Import multiple data files: Simultaneously load data spread out across
multiple files
In R2016a, you can import multiple data files at once. Previously you could only import a single data
file at a time.

See Load and Edit Data and Merge Data.

Data merge with strict matching: Check variables and units and only
merge when all match
Smarter merging helps you to avoid merging in the wrong data.

See Merge Data.

Data preprocessing reuse: Reuse filters, user-defined variables, and
plot layouts from the current project or other project files
Import filters, user-defined variables, and plot layouts from other data sets in the same project, or
import from other project files. You can reuse your previous definitions without needing to save them
to a separate file.

See Import Variables, Filters, and Editor Layout.

Augment existing space-filling designs: Continue Sobol and Halton
sequence to fill in the spaces when you want to collect more design
points
When you want to collect more data, you can now add design points that continue the same space-
filling sequence in your original design. This allows you to collect more data filling in the gaps
between your previous design points.

Previously you could add more design points but only randomly or by manually specifying new points,
which made it difficult to fill in spaces in the prior design points.

See Adding and Editing Design Points.

Simplified workflow for importing, merging, and manipulating data
Working with data for modeling is simplified in R2016a. New capabilities include:

• Filters and variables report success or failure
• Easier grouping and ungrouping of data
• Import or export to tables
• New default views to simplify plotting data

See Create Variables, Create Filters, and Define Test Groupings.
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Simplified workflow for creating and constraining designs
Working with designs is simplified in R2016a. New capabilities include:

• Create a table constraint by importing from a CAGE table or normalizer
• When generating a space-filling design, the design editor now tries to provide points as close as

possible to the number of points you specified. You no longer need to specify a larger number until
you get the desired number of points within the constraints.

• When defining 2D constraints, you can now view a plot and table of points at the same time
without needing to switch tabs.

• You can create and import constraints in a single dialog box instead of two.
• The Design Editor toolbar is simplified to show only frequent tasks.

See Define Design Constraints and Creating a Space-Filling Design.
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Gaussian process models for improved default fits
Gaussian process models (GPM) are popular nonparametric regression models used in model-based
calibration. Gaussian process model is the new default model type for one-stage models and is now
included in default point-by-point models. If you want to try all kernels and basis function options, use
the new Gaussian Process model template to build a selection of Gaussian process models.

For details, see Global Model Class: Gaussian Process Model.

Tip To view example models, see Gasoline Engine Calibration.

Compatibility Considerations
Model Browser one-stage and point-by-point default models are a different type from previous
releases.

To use the previous default model types, you can set up any model type from the test plan or the Edit
Model common task in the model views.

Model Type New Setting Previous Setting
Default one-stage models Gaussian process models Hybrid radial-basis function

(RBF)
Point-by-point models Default model types:

• Quadratic with Stepwise:
Min PRESS

• Cubic with Stepwise: Min
PRESS

• Hybrid RBF with nObs/3
• Gaussian process models

(using defaults)

Default model types:

• Poly2 with Stepwise: Min
PRESS

• Poly3 with Stepwise: Min
PRESS

• Hybrid RBF with nObs/4
• Hybrid RBF with nObs/3
• Hybrid RBF with nObs/2

Point-by-point models selection
criteria default: PRESS RMSE

AICc

Create Alternative Models Selection criteria default: AICc
if available, otherwise PRESS
RMSE (for GPM)

AICc

Note For large data sets, the toolbox also uses new default models and boundary models. See
“Faster Default Models for Large Data Sets” on page 10-4.

For information on all default model types, see Default Model Types.
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Cross section and response surface views for assessing goodness of
fit in MBC Model Fitting app
Improved model fitting and selection workflows for one-stage, two-stage and point-by-point models.
Assess goodness of fit by viewing model trends and statistics in the main app.

• The new cross-section view provides a quick view of trends in all your response models at the
same time.

• View the response surface as soon as you fit an initial model, to inspect model trends. You can
view surfaces, multiline, contour and validation plots.

• View the RMSE for all tests at once to help identify and navigate to problem fits.
• New common tasks links provide access to the frequent tasks for each model view.

For details, see Model Assessment.

Tip To view example models, see Gasoline Engine Calibration.

Alternative model exploration and comparison in MBC Model Fitting
app
• You can compare alternative models and select the best models in the Model Browser.
• You can select models by viewing useful plots all at once (for example, surfaces, contour, and

RMSE plots). You no longer need to open additional windows such as the Model Selection window
or RMSE Explorer plots.

• New common tasks links provide access to the frequent tasks for each model view.

For details, see Alternative Model Exploration.

Tip To view example models, see Gasoline Engine Calibration.

Simplified workflow for point-by-point models
Point-by-point model views now show alternative models. You can compare and select the best model
for each operating point with no need to open the additional Model Selection window. You can use
surface plots, data plots, and other plots to assess and compare models. You can use the RMSE plot to
identify and navigate to problem tests.

Alternative model fits are now saved so it is faster to switch models and select a different model as
best. If you open existing projects, you are prompted to refit the alternative models to store.

Point-by-point models are now immediately below the test plan node in the model tree, instead of
reusing the local model node.

For details, see Assess Point-by-Point Models.
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Automatic parallel execution of optimizations using Parallel
Computing Toolbox
Optimizations automatically use Parallel Computing Toolbox when it is available. Previously you had
to manually select parallel optimization.

For details, see Parallel Computing in Optimization.

Improved performance for parallel optimizations
Optimization speed when using Parallel Computing Toolbox is significantly faster because of
improved transfer of data to the workers.

Changed Optimization Default Algorithm
New optimizations use the interior-point algorithm for fmincon. This is the default in
Optimization Toolbox™.

Compatibility Considerations
Existing projects are not affected by the change in algorithm. New optimizations will use the new
default algorithm. Usually, the new algorithm is faster and more robust. You can still select the
previous default algorithm (active-set) if desired. This change affects: foptcon, NBI, and Modal
optimizations.

Faster Default Models for Large Data Sets
When you fit models to data and the data set is larger than a threshold, the toolbox uses new default
models and boundary models.

Model Type Data Set Size Boundary Model Large Data Settings
One-stage >2000 points Switches to pairwise

convex hull.
Switch when >10 inputs
even when <2000
points.

Uses the large data
behavior for Gaussian
process models from
Statistics and Machine
Learning Toolbox.

Two stage >2000 tests Global boundary model
switches to pairwise
convex hull.
Switch when >10 inputs
even when <2000
points.

Global model switches
to quadratic.
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Model Type Data Set Size Boundary Model Large Data Settings
Point-by-point If any test >2000

points, or >100
operating points

If any operating point
has >2000 points, then
point-by-point boundary
model switches to
pairwise convex hull.
Switch when >10 inputs
even when <2000
points.

Switches to fitting a
single GPM per
operating point (no
Hybrid RBF or
polynomial).

For information on all default model types, see Default Model Types.

Compatibility Considerations
Existing projects are not affected. New model fitting will use the new default settings. You can still
select any other model types after fitting models to data.

Changes to Feature Filling Algorithm
Feature-filling projects switch to interior-point algorithm for fmincon if you have table gradient
constraints.

Compatibility Considerations
Existing projects switch to interior-point algorithm if you refill lookup tables.

New Gasoline Case Study Example
The gasoline case study shows how to systematically develop a set of optimal steady-state engine
calibration tables using the Model-Based Calibration Toolbox. The engine to calibrate is a direct-
injected 1.5L spark ignition turbocharged engine with dual camphasers and turbocharger wastegate.
The toolbox provides example files to show each stage of the model-based calibration process: design
of experiment, empirical engine modeling, and optimization.

For details, see Gasoline Engine Calibration.
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Common Tasks pane for fitting statistical models to data
If you want to load data and fit models, the Model Browser provides new tools to create models
quickly. When you open the Model Browser, you can click common tasks to import data or fit models.

Importing data is simplified. You can click the common task to load data from a file or the workspace
before opening the Data Editor. You can now import table objects from the workspace. You can also
load data during the model fitting task.

When you click the Fit Models task, new dialog boxes help you select data and responses to model.
The toolbox fits responses using the new default model type, Hybrid radial basis functions. Input
names and ranges are taken from the data set. The toolbox also fits boundary models for you.
Optionally, you can select a subset of your data for validation, and the Model Browser plots validation
data with your model plots.

After fitting models, the Model Browser shows the next common tasks in the test plan view, to guide
you on the next step in the workflow. You can click the common tasks list to generate a calibration or
export models to Simulink.

The workflow is simplified compared to previous releases, when creating test plans was the first step
for both fitting data and creating designs. Separating these workflows helps you get started with
fewer options to choose. If you only want to load data and fit models, many fewer steps are required
and the toolbox creates models using better defaults. You no longer have to interact with the test plan
diagram to set up your models. You no longer need to match signal names, decide to copy data
ranges, or choose model settings unless you want to.

For details, see Modeling Workflows.

Design Experiment dialog box for specifying input factors
To create a design when you open the Model Browser, click the Design Experiment task. A new dialog
box guides you through specifying inputs and ranges for your design.

The workflow is simplified compared to previous releases. You no longer have to interact with the test
plan diagram to set up your inputs. After you create your design and collect data, the Model Browser
common task options Import Data and Fit Models guide you through the next steps. The new default
model type, Hybrid radial basis functions, can produce better fits.

For details, see Set Up Design Inputs and Fit Models to Collected Design Data.

Genetic algorithm for global optimization of multiobjective drive cycle
problems
You can use the new gamultiobj optimization algorithm in the CAGE browser. This algorithm is only
available if you have Global Optimization Toolbox installed.

The gamultiobj algorithm is good for multiobjective optimizations with more than two objectives or
those that are not smooth. Such problems can work better with gamultiobj than with the previous
option for multiobjective optimizations, the NBI algorithm.

Analyzing results from these problems is easier with improved Pareto plots. The Pareto plot displays
solution status highlighting of successful and unsuccessful solutions (Pareto, dominated, or
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infeasible). Pairs of objectives are plotted against each other, so you see three plots for three
objectives. Repeated axes and empty diagonal plots have been removed.

For details, see Set Up Multiobjective Optimizations and Analyzing Multiobjective Optimization
Results.

Code generation of exported models with Simulink Coder, by
exporting using MATLAB Function blocks
All model types are exported to Simulink using MATLAB Function blocks. This enables code
generation for deploying, sharing, and executing Model-Based Calibration statistical models using C
code.

In R2014a, only polynomial models could be deployed. In previous releases, exported models
contained S-functions instead of MATLAB Function blocks.

To deploy a model, ensure the Inline parameters option is on. The option is on by default when you
export to Simulink. If you copy a block to another system, then set the option before building the
exported block into an S-function.

For details, see Export Models to Simulink.

Changed model defaults and automatic boundary model creation can
produce better fits
The Model Browser new default models are Hybrid radial-basis functions (RBFs), which can usually
produce a good fit the first time. The Model Browser also automatically creates boundary models for
your global inputs using the convex hull type.

Hybrid RBF and RBF models have some new defaults and new parameters to produce better fits.
These new settings work better for larger data sets, to choose more centers in a better distribution.
The fitting algorithm selects up to 50% of the data as centers. Limits start to apply to data sets with
>2000 observations. New parameters improve regularization and center selection to reduce
overfitting.

You no longer need to interact with the test plan diagram to set up model types or open the Boundary
Editor to create boundary models.

For details, see Modeling Workflows.

Compatibility Considerations
Model Browser default models are a different type from previous releases.

To use the previous default model types, you can set up any model type by interacting with the test
plan diagram or the Boundary Editor.

Model Type New Setting Previous Setting
Default response models Hybrid radial-basis function

(RBF)
Quadratic
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Model Type New Setting Previous Setting
Default boundary models Convex hull for global inputs,

automatically created
Star-shaped, manual setup, and
you had to choose local or
global inputs

Hybrid RBF and RBF models Maximum number of centers,
default min(nObs/3,1000)

min(nObs/4,25)

Candidate centers, default
min(100,(2000/nObs)*100)

min(100,(200/nObs)*100)

Center tolerance, default 0.01,
to avoid centers too close
together.

N/A. To replicate old behavior,
set to 0.

Number of terms to update
between updating regularization
parameter, default 10.

N/A. To replicate old behavior,
set to 1.

Stepwise defaults: Prune, AICc Minimize PRESS
Multiple models Default model types:

• Poly2 with Stepwise: Min
PRESS

• Poly3 with Stepwise: Min
PRESS

• Hybrid RBF with nObs/4
• Hybrid RBF with nObs/3
• Hybrid RBF with nObs/2

Default model types:

• Poly2 with Stepwise: None
• Poly3 with Stepwise: None
• Old default RBF
• Old default Hybrid RBF

Multiple models selection
criteria default: AICc

RMSE

Build Models feature Selection criteria default: AICc RMSE

Import of table objects from the MATLAB workspace
In R2014b, the Model Browser provides the following improvements to data handling:

• You can import table objects from the MATLAB workspace.
• You can select Data > Import Data from Workspace in the project view when you open the

Model Browser. This simplifies importing data, because you no longer need to open the Data
Editor before loading data.

• You can create test filters for records within tests as well as whole tests. For example, abs(SPK-
mean(SPK))<10 keeps all records where SPK is within 10 of the test mean.

• You no longer need to reconfigure Data Editor views because it remembers layouts for each data
set.

In CAGE, you can import and export between the workspace and CAGE data sets, including table
objects. Export creates a table object.

For details, see Loading Data from the Workspace.

R2014b
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Table editing options to copy, convert, and preserve extrapolation
masks and lock table values
CAGE provides new tools for easier locking and extrapolation from desired table values:

• Copy masks and locks from other tables
• Convert masks to locks and vice versa
• Extrapolate using masks and locks rather than just locks
• Smoother extrapolation to locked table cell values
• Revert to previous table version without losing extrapolation mask
• Simplified table inversion

For details, see Filling a Table by Extrapolation and Locking Table Values.

Mask generation from predictive error variance and boundary models
You can generate masks from PEV and Boundary models for any table in CAGE. In previous versions
this was only possible if the table was part of a feature calibration.

For details, see Filling a Table by Extrapolation.

Lookup table shading for relating table values to surface plots
CAGE provides new tools for visually exploring tables. Table cells background color now matches the
corresponding 3D surface plot color.

Surface plots of tables are transposed to match the numerical table axes and other calibration tools.

Table and plot are now stacked vertically for better use of screen space.

For details, see Viewing and Editing a Table.

Summary information for lookup table size, bounds, normalizers,
inputs, and history
Table information now displays size, bounds, normalizers, inputs and history in a single place. The
Table Information pane provides easier access to the table history to revert to previous values.

For details, see Viewing and Editing a Table.

Tradeoff plots that zoom inside constraint boundaries
Improved zoom capability in tradeoff plots allows you to set the axes limits to the constraint
boundary. This zooms the tradeoff plots inside the constraint boundaries to explore competing
objectives in valid regions only. Select View > Zoom Inside Constraints. This reduces the y axis
scale as the plots do not include regions where the model is extrapolating.

See Choosing a Table Value at a Specific Operating Point.
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Polynomial model deployment
Polynomial models exported to Simulink are now implemented as MATLAB Function blocks. This
enables code generation for deploying, sharing, and executing Model-Based Calibration statistical
models using C code.

See Export Models to Simulink.
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Import of more Math Operation Simulink blocks and subsystem
hierarchy, enabling more complex calibration strategies
In R2013a, the CAGE Browser includes new and improved features for importing Simulink models
into CAGE for feature calibration with reference to statistical models. New features include:

• Import strategies with multiple out ports.
• Import a strategy hierarchy by creating subfeatures for each subsystem. This makes it easier to

understand how the model strategy corresponds to the features in CAGE.
• Reuse tables when importing strategies. CAGE reuses existing tables if they have the same inputs.

If tables with the same name use different inputs, CAGE asks what you want.
• Switch blocks now support all operators. Previously CAGE could only parse >=.

See Import a Strategy from Simulink.

Compatibility Considerations
2D tables now use Y (rows), X (columns) input order to be consistent with Simulink. Previously, CAGE
parsed the first input as columns and the second as rows. You can use a backward compatibility mode
if needed for previously saved strategies.

The Graphical Strategy Editor provides a left to right flow, consistent with Simulink. Previously, the
single output was on the left with the strategy on the right.

See Importing Older Strategies.

Import and export of table values and breakpoints in Simulink model
strategies
When you import strategies into the CAGE Browser, you can import lookup table values from
Simulink into CAGE tables, so you can get table and normalizer data.

See Import a Strategy from Simulink.

Configuration and storage of multiple fill settings for feature filling
processes
In the CAGE Browser Feature view, new information panes display all the tables in a feature and any
filling factors already set up. You can store, view, and reuse feature filling settings for any of the
tables from the top Feature view.

See Saving and Reusing Feature Fill Settings.

Case study example showing calibrating a multi-injection diesel
engine
R2013a includes new example files showing how to systematically develop a set of optimal steady-
state calibration tables for a diesel multi-injection engine using Model-Based Calibration Toolbox.

R2013a
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The engine to be calibrated is a 3.1L multi-injection combustion ignition engine with common rail,
variable-geometry turbocharger (VGT), and cooled exhaust gas recirculation (EGR).

The aim of the calibration is to minimize Brake Specific Fuel Consumption (BSFC) at specific speed/
load operating points across the engine’s operating range, and meet the following constraints:

• Limit total NOx emissions.
• Limit maximum turbocharger speed.
• Limit calibration table gradients for smoothness.

The analysis produces optimal calibration tables in speed and torque for:

• Best main start of injection timing
• Best total injected fuel mass per cylinder per cycle
• Best pilot injection timing relative to main timing
• Best pilot injection fuel mass fraction of total injection mass
• Best exhaust gas recirculation (EGR) position
• Best variable geometry turbocharger (VGT) vane position
• Best fuel rail pressure relative to nominal pressure vs. engine speed

See Multi-Injection Diesel Calibration.

Use model ranges from point-by-point models as optimization bounds
In R2013a, the CAGE Browser uses model ranges from point-by-point models instead of data variable
ranges. Providing more precise bounds can help optimizations to converge quicker. For point-by-point
models, the variable ranges can be much larger than the bounds for a particular operating point.

In previous releases, CAGE used data variable ranges instead of model ranges. If the data ranges for
operating points differ widely across model operating points, this could cause optimizations to run
more slowly or fail to converge. The data range often contains large infeasible parts of the space
between the bounds that are outside the boundary model constraint. Using more precise model
ranges can help the optimization find a feasible result.
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Table filling from optimization results, when optimization operating
point inputs are different from table inputs
For some optimization problems, you want to optimize at operating points in different variables to the
tables you want to fill, and use response models as normalizer inputs to tables. For example, if your
problem requires running an optimization at torque and speed operating points, but you want to fill
lookup tables on axes of mainfuel (a response model) and speed.

Previously, it required many manual steps to create and fill such tables from your optimization
results. The toolbox now provides tools to quickly create tables with response models as normalizer
inputs, and select such tables to fill with your optimization results. Now you can use your
optimization results to fill lookup tables with different inputs to your optimization operating point
inputs.

See Creating Tables From a Model and Table Filling When Optimization Operating Point Inputs are
Different From Table Inputs.

Overlay of validation data on boundary model plot views
You can now choose to plot validation data on boundary model plots. This is useful for investigating
where validation data lies in the operating envelope compared to the original points used to fit the
model.

See Plotting Boundary Models.
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Smaller Project File Sizes
CAGE and Model Browser file sizes are reduced by up to 95% for point-by-point projects, enabling
easier file sharing.

More Efficient Boundary Modeling
More efficient boundary modeling contributes to reducing file sizes. Identical boundaries are shared
between response model fits instead of duplicated.

The convex hull model is simplified for more efficient boundary modeling. In a typical example, using
8 factors and 70 points results in a convex hull with around 35,000 faces. By default, the boundary
model now keeps only the most useful facets and can discard around 30% of the facets because they
contribute only a small amount to the boundary. The new method is more efficient and includes all
data points within the boundary, with the total volume increasing by around 1%. If you want the
minimal volume at the expense of a much larger number of facets, you can select a new option, Keep
All Facets.

See Boundary Model Setup in the Model Browser documentation.

Stored Feature Filling Settings
CAGE projects now store last-used settings for tables, models, data, and optimizations for feature
filling. The Feature Filling Wizard can require many steps to set up and you might need to repeat this
process many times. Stored settings can save time when using the Feature Filling Wizard repeatedly
with slightly different settings.

You can remove saved fill settings using a new menu item, Feature > Reset Fill Settings.

See Performing Feature Calibrations in the CAGE documentation.
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Improved Design Creation
The design creation process is improved to help you save time and choose good settings for
generating efficient candidate sets. The toolbox now warns you if you try to generate a large
candidate set of points that will take a long time. Previously, you could try to generate candidate sets
that were so large that you could run out of memory. The toolbox now warns and gives you the option
to stop and change settings to create a better design more quickly. The toolbox also provides
suggestions for better alternative settings.

Support for the Windows 64-Bit Platform
A 64-bit version of Model-Based Calibration Toolbox software is now available for users of 64-bit
Windows® and the 64-bit version of MATLAB.

Note the 32-bit version of Model-Based Calibration Toolbox also works on a 64-bit version of
Windows, but requires a 32-bit version of MATLAB.

64-bit support required some changes to the appearance of trees in CAGE. Projects in CAGE have a
new root project node in the tree. There is no functionality at this project node.

R2011b
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Extra Objectives for Modal Optimization Analysis
You can now specify more than one objective for graphical comparison in modal optimization. You can
optimize with one objective, and use the other objectives to explore the results. You can optionally
choose a different objective to use to select the best mode.

See Adding Extra Objectives to Modal Optimizations and Analyzing Modal Optimization Results in the
CAGE documentation.

New MultiStart Algorithm to Find Local Optima and Create Smoother
Tables
If you have Global Optimization Toolbox you can now use the MultiStart algorithm in CAGE. This
algorithm tries to identify local optima to help you create smoother tables. Multiple local optimal
solutions are often found because of the flat nature of engine responses. The difference in
performance between these different solutions can be small and result in tables that are not smooth
enough. The new MultiStart algorithm tries to identify multiple optimal solutions for each operating
point. You can select the solutions that meet your table smoothness constraints based on the entire
table.

See Set Up MultiStart Optimizations and Analyzing MultiStart Optimization Results in the CAGE
documentation.

Tradeoff Tool Plots Local Model Ranges
The Tradeoff tool in CAGE now automatically scales plot axes to the local range when switching
between different point-by-point models. This avoids having to manually zoom on each graph from the
global range to the range of interest.

See Point-by-Point Model Tradeoffs in the CAGE documentation.

Defer Fit Updates
In the Model Browser, you can now delay lengthy updates of dependent fits when leaving the local
node. This can be useful when you want to examine a particular global model after removing an
outlier at the local level. Defer updates to avoid waiting while updating all other dependent fits.

See Updating Fits in the Model Browser documentation.

Simplified Parallel Model Building
To use parallel processing with model building, you no longer have to use the mbcmatlabpool
function as well as the matlabpool function. The removal of mbcmatlabpool simplifies parallel
model building by reducing the number of setup steps.

See Parallel Model Building in the Model Browser documentation.
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Equality Constraints
Version 4.1 provides the ability to define equality constraints on models. The feature enables you to
optimize performance while meeting demanded operating conditions. See Model Constraints in the
CAGE Optimization Setup documentation.

For an example, see Setting Up Constraints in the Getting Started Diesel Case Study.

Feature Filling with Data
You can now fill features directly from experimental data using the Feature Fill wizard. This wizard
now enables you to fill feature tables without a model.

You can use data sets in the Feature Fill wizard to fill features over irregular data sets, without
gridded data.

See Filling and Optimizing Table Values in the CAGE Feature Calibration documentation.

Data Transfer Between CAGE and the Model Browser
In Version 4.1, you can directly transfer data between Model Browser and CAGE without saving an
intermediate file. In CAGE, you can now import data directly from the Model Browser, and export
data to the Model Browser.

See Importing Data from the Model Browser and Exporting Data to the Model Browser in the CAGE
Data Sets documentation.
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Modeling Enhancements
• “New Composite Models for Multiple Operating Modes” on page 21-2
• “Update Models with Additional Data” on page 21-2
• “Improved API for Export Models” on page 21-3

New Composite Models for Multiple Operating Modes

Version 4 of Model-Based Calibration Toolbox enables you to produce optimal calibrations for engines
with multiple operating modes. You can use the new composite model type to combine a number of
models to represent engine responses under different operating modes. You can use the composite
model in CAGE to produce optimal calibrations for engines with multiple operating modes. Use for
calibration problems where the goal is to fill a single table for all modes or to fill a table for each
mode.

You can create a composite model by either:

• Importing to CAGE from the Model Browser
• Combining existing models in CAGE

The composite model consists of a collection of models with an extra mode input. The mode input is
an index into the list of models. The component models can have different sets of inputs.

See Creating and Viewing Composite Models in CAGE in the CAGE documentation.

New example projects are provided to illustrate using the new features to produce optimal
calibrations for diesel and gasoline engines with multiple operating modes. See Example Composite
Models and Modal Optimizations in the Getting Started documentation.

Update Models with Additional Data

You can now update test plans in the Model Browser with new data points while retaining boundary
models and validation data.

Previously, when you updated test plan data, the toolbox deleted boundary models and validation
data. The toolbox retained local fits, including your outlier selections, if their test data was
unchanged after adding new test plan data.

In R2010a, when you update test plan data, the toolbox refits boundary models and retains validation
data. Thus, you have less rework to do when fitting models as you collect more data.

The test plan data update functionality is particularly important for building two-stage or point-by-
point models. You can load local models into the Model Browser as you collect the data. The update
functionality ensures that you do not lose current work when you load data for new tests. The update
functionality is also useful when you augment a one-stage design because you need more data to
build an accurate model.

Input signal names need to match when update test plan data. The toolbox deletes boundary models
and validation data if the input signal names change.

To update data for a test plan, use the Select Data toolbar button or the TestPlan menu item. See
Use Test Plans to Set Up Designs, Data, and Models in the Model Browser documentation.
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Improved API for Export Models

This release introduces improved command-line API support for exporting models. This support
includes new methods for calculating confidence intervals and prediction error variance for models.
See Export and xregstatsmodel in the Reference documentation.

Optimization Enhancements
• “New Optimization Algorithm for Multiple Operating Modes” on page 21-3
• “Table Gradient Constraints of Models” on page 21-3
• “Filter Rules for Table Filling” on page 21-4
• “Incremental Table Filling” on page 21-4
• “Support for New Version of ATI VISION” on page 21-5
• “New Optimization Parameters” on page 21-5

New Optimization Algorithm for Multiple Operating Modes

Version 4 of Model-Based Calibration Toolbox enables you to produce optimal calibrations for engines
with multiple operating modes. You can use the new Modal optimization algorithm to select optimal
operating modes for such calibrations. This algorithm helps you choose the best operating mode for
each operating point. The algorithm can optimize an objective for each operating mode and select the
best solution automatically. You must use a composite model for these optimizations.

This release also introduces enhanced optimization output views to help you view the solutions and
decide which mode you want to use for each operating point. The enhanced views make it easier to
see which solution is selected and to change the selection. These features are also useful for selecting
solutions for multiple objective optimizations such as NBI.

You can only use modal optimization for point optimization problems. When you have selected the
best mode for each operating point, you can create a sum optimization from your modal optimization
results. The toolbox automatically creates a sum optimization for you with your selected best mode
for each operating point. For more information see Set Up Modal Optimizations in the CAGE
documentation.

New example projects are provided to illustrate using the new features to produce optimal
calibrations for diesel and gasoline engines with multiple operating modes. See Example Composite
Models and Modal Optimizations.

Table Gradient Constraints of Models

With R2010a you can apply table gradient constraints to models to restrict optimal solutions to
smooth responses. Previously, you could only constrain the table gradients of variables. Optimal
calibrations need constraints on both model responses and variables. You can now specify a maximum
gradient for engine responses as well as control inputs.

Sometimes the inputs for testing differ from the inputs for tables. In such cases, engineers often use a
model to derive the table input. To constrain the table gradient you need to define a gradient
constraint for models. You can also define a constraint on the smoothness of the engine response for
drivability.
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You can define a table gradient constraint for any free variable in your optimization or any model that
has a free variable as an input. The Edit Constraint dialog box for the table gradient constraint has
been rearranged to simplify workflow.

You can only use table gradient constraints for sum optimizations because the toolbox needs multiple
operating points to estimate the table. If you require filling rules to select part of the optimization
results for filling, then use the table gradient constraints in combination with application point sets.
In particular, if your goal is to fill different tables for each mode, then define application point sets for
each mode. For an example, see

Composite Model Example with Separate Tables for Each Mode in the Getting Started
documentation.

Filter Rules for Table Filling

You can now apply filter rules to select part of the optimization results for table filling. You can
specify an operating mode or any valid expression as a filter when using the Table Filling wizard.

The filter rules are important for modal optimizations. Composite models can require the ability to
select part of the optimization results to fill a particular table. For example, you need to discard
solutions for other modes when filling a table with an input that is not used for all modes.

• Use filter rules when your goal is to fill a different table for each mode.
• Specify a filter rule with a logical expression using any input or model available for use in table
filling.

• The Table Filling from Optimization Results wizard automatically sets up filter rules for you if
some inputs are not used for all modes in your composite model.

For an example, see Filling Tables for Operating Modes in the CAGE documentation.

Incremental Table Filling

New settings in the table filling wizard enable you to incrementally fill lookup tables from the results
of multiple optimizations with smooth interpolation through existing table values. CAGE can
extrapolate the optimization results to pass smoothly through table masks and locked cells. Use these
features when you want to use separate optimizations to fill different regions of a lookup table.

Use the new check boxes in the Table Filling from Optimization Results wizard to specify when you
want to:

• Use locked table values in extrapolation.

If your calibration tables have fixed values for some table cells, use locked cells for the table cells
with fixed values. Such cells often appear on the edge of a table.

Select this check box and CAGE smoothly fills the table between fixed table values and
optimization results.

• Use existing extrapolation mask in fill.

Select this check box when you want to fill the same table from multiple optimizations that
provide solutions at different operating points. Complex calibration problems can require different
optimizations for different regions of a table. The toolbox automatically adds filled cells to the
table mask.

R2010a
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Select this check box for subsequent table filling. CAGE smoothly fills the table between the
values in the mask (from previous table filling) and the current optimization results.

See Filling Tables from Optimization Results in the CAGE documentation.

Support for New Version of ATI VISION

The toolbox now supports ATI VISION Version 3.5.1.

You can import and export calibrations directly from/to ATI Vision (via a live link or .mat files). See
Importing and Exporting Calibrations in the CAGE documentation.

New Optimization Parameters

A new setting in the Optimization Parameters dialog box for the foptcon algorithm allows you to
choose one of the fmincon function algorithms: active-set, sqp, interior-point. First try the
default, active-set, the only option in previous releases. If you have sum optimizations which are
slow or have problems converging, you can try the new sqp or interior-point options. For details
of sqp see New fmincon Algorithm in the Optimization Toolbox release notes.

To use the new options in CAGE, see the Constraint optimization algorithm setting described in
Edit Optimization Parameters in the CAGE documentation.

New Example Projects for Calibrating Engines with Multiple Operating
Modes
Version 4 of Model-Based Calibration Toolbox enables you to produce optimal calibrations for engines
with multiple operating modes. Examples of applications include: multi-injection diesel engine;
inclusion of startup conditions in drive cycles; rich and stoich regions for engines.

New example projects are provided to illustrate using the new features to produce optimal
calibrations for diesel and gasoline engines with multiple operating modes. See Example Composite
Models and Modal Optimizations in the Getting Started documentation.
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Optimization Tools
• New wizards to automate creating an optimization, tables, and tradeoff from a model. The wizards

simplify common calibration workflows to create optimizations, and related tables to fill with
optimization results, and tradeoffs for investigating results. These utilities make these workflows
easier and faster by eliminating many manual steps. See:

• Creating Optimizations from Models in the CAGE documentation.
• Creating Tables From a Model in the CAGE documentation.

• Enable difficult diesel calibrations problems by evaluating optimization objectives and constraints
over different drive cycles. See Using Application Point Sets in the CAGE documentation.

• Improved tools to analyze and export multi-objective optimization results: an exit flag per solution,
improved exit messages, only successful solutions shown on pareto plots, and the ability to export
all solutions. See Tools for Optimizations With Multiple Solutions in the CAGE documentation.

• Ability to duplicate and import optimization constraints. See Edit Objectives and Constraints in the
CAGE documentation.

• New dialog box for selecting calibration items for export. See Exporting Calibrations in the CAGE
documentation.

Modeling Tools
• New API for creating and evaluating boundary models, vital for constraining online Design of

Experiments (DOE). See Boundary Model Scripting in the Getting Started documentation.
• Ability to negate design constraints, for example, if you want to constrain points to be outside a

boundary model. See How to Apply Constraints in the Model Browser documentation.
• New model type: interpolating RBF to fit an interpolating surface that passes through every data

point. See Global Model Class: Interpolating RBF in the Model Browser documentation.

Point-By-Point Case Study
• New case study demonstrating how to use the tools for a point-by-point diesel engine calibration

project. The instructions and example files show you how to:

1 Programmatically create designs, models, and boundary models at each operating point.
2 Interactively create a multiregion sum optimization, with a constraint applied only at full load

points, and a second drive cycle with different weights to evaluate the optimization results at
intermediate points.

For instructions see Point-by-Point Diesel Engine Calibration Case Study.
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Optimization Enhancements
• Usability improvements including:

• The new Table Filling Wizard makes it easier to fill a single table from a model. The wizard
automates this process and eliminates a number of manual steps. See Filling a Table From a
Model in the CAGE Browser documentation.

• Utility to automatically create a sum optimization from the results of a point optimization. A
common workflow is to use a point-by-point optimization to find good initial values for a sum
optimization. This utility makes this workflow easier and faster by eliminating a number of
manual steps. See Create Sum Optimization from Point Optimization Output in the CAGE
Browser documentation.

• CAGE Surface Viewer snaps display automatically to point-by-point model operating points.
When you are using point-by-point models, these are the points of interest you want to display.
See Displaying Point-by-Point Models in the Surface Viewer in the CAGE Browser
documentation.

• Support for ATI VISION 3.5. See Importing and Exporting Calibrations in the CAGE Browser
documentation.

Modeling Enhancements
• Usability improvements including:

• New navigation ability in RMSE explorer. You can double-click points to select the test in
Model Browser views. This helps you investigate problem tests and avoids the need to enter
the test number in the Model Browser. See Using the RMSE Explorer with Local Models in the
Model Browser documentation.

• Process for augmenting space-filling designs. These instructions explain how to augment your
space-filling design by keeping your existing points and adding points with the same sequence
parameters. See Augmenting Space-Filling Designs in the Model Browser documentation.

• CAGE and the Model Browser open projects at last displayed node. This memory of your last
project view avoids the need to remember where you were working and the Browsers
automatically navigate there.
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Boundary and Point-By-Point Modeling
• Improved Boundary Editor workflow. Menus, dialog boxes, and the toolbar are simplified to

streamline creation of boundary models. See Boundary Model Setup in the Model-Based
Calibration Toolbox Model Browser documentation.

• Enhancements to point-by-point modeling tools that are useful for diesel engine modeling. You can
use a new template for creating point-by-point test plans with local models at each engine
operating point. You can now create boundary models for point-by-point test plans in the Boundary
Editor. Boundary model constraints are now displayed for local models in the Model Selection
window to help you evaluate your point-by-point models. Exporting your point-by-point models
now automates creation of items for optimized calibration in CAGE. See Set Up a Point-by-Point
Model.

R2008b

24-2

https://www.mathworks.com/help/releases/R2012a/toolbox/mbc/model/bq6zpt1-1.html
https://www.mathworks.com/help/releases/R2012a/toolbox/mbc/model/brsdkbd-1.html
https://www.mathworks.com/help/releases/R2012a/toolbox/mbc/model/brsdkbd-1.html


R2008a+

Version: 3.4.1

Bug Fixes

25





R2008a

Version: 3.4

New Features

Bug Fixes

26



New Design Tools
• Create space-filling, optimal, classical, or custom designs interactively using new command-line

functionality. See the toolbox examples, and design scripting documentation.
• New Sobol and Halton sequence space-filling design types can provide highly uniform

experimental designs. See Halton Sequence and Sobol Sequence in the Model-Based Calibration
Toolbox Model Browser User's Guide documentation.

Optimization Multistart, Surface and Contour Views
• New optimization output contour and surface views that aid in the assessment and use of results

for generating optimal lookup tables. See Solution Slice: Results Surface and Results Contour
Views in the Model-Based Calibration Toolbox CAGE User's Guide documentation.

• Improved generation of multiple starting conditions to help detect global optima with gradient-
based optimization algorithms. See Edit Optimization Parameters in the Model-Based Calibration
Toolbox CAGE User's Guide documentation.

Parallel Model Building
Use parallel computing to speed up model building (requires Parallel Computing Toolbox license). See
Parallel Model Building in the Model-Based Calibration Toolbox Model Browser User's Guide
documentation.
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Design Tools
• Command-line definition of inputs for test plans and models.

See modelinput in the Model-Based Calibration Toolbox Reference documentation, and for
examples see Scripting Demos in the Model-Based Calibration Toolbox Getting Started Guide
documentation.

• Extended command-line functionality for creating, editing, and fitting local models.

See LocalModel Properties in the Model-Based Calibration Toolbox Reference documentation, and
for examples, see Scripting Demos in the Model-Based Calibration Toolbox Getting Guide
documentation.

• Enhanced defaults and previews for space-filling designs, including performance increases, design
property improvements, and improved handling of constrained design points. The new defaults
are faster to compute and provide symmetrical designs with better space-filling properties. The
default Selection criteria is now Minimize RMS variation from CDF, and Enforce
Symmetrical Points is now selected by default.

The number of constrained design points are now displayed in the Design Browser preview, where
you can iterate design generation until the desired number of constrained points is achieved. The
preview design is now identical to the final design.

See Setting Up a Space-Filling Design in the Model-Based Calibration Toolbox Model Browser
User's Guide documentation.

Optimization Setup and Analysis Tools
• Enhanced optimization set up and analysis, including support for boundary constraint definition in

the optimization wizard, ability to rename objectives and constraints, and improved display of
table gradient constraints.

You can now use a right-click shortcut to convert an existing constraint to a boundary model
constraint without opening the Constraint Editor. Table gradient constraint output is simplified in
the Optimization Output Table and Constraint Summary table to aid analysis, and these
constraints are faster to display.

See Overview of Objectives and Constraints in the Model-Based Calibration Toolbox CAGE User's
Guide documentation.

• New process suggestions for analyzing optimization results, with advice for detecting problems
and improving results.

See Analyzing Point Optimization Output in the Model-Based Calibration Toolbox CAGE User's
Guide documentation.
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Modeling API
Extended command-line API to setup models for use as standalone objects or as part of MBC projects.
See DIVCP Example.

Accepting Optimization Solutions
New tools to assist in the assessment and use of optimization results for producing optimal lookup
tables. See Choosing Acceptable Solutions.

Parallel and Global Optimizations
• Use distributed computing to speed up multiple run optimizations (requires Distributed

Computing Toolbox™). See Parallel Computing in Optimization.
• Use Genetic Algorithms and Pattern Search to find globally optimal solutions (requires Global

Optimization Toolbox). See Choose Optimization Algorithm.
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Optimization Enhancements
• Gradient constraints for controlling table smoothness in optimization-based and feature-based

table filling
• Contour plot view for optimization results
• Point-by-point variable bounds for finer control of optimization problems
• Ability to enable and disable optimization constraints for “what if” studies
• Support for starting optimizations from the results of a previous run

• Solve related “what if” problems faster
• Refine calibration results by tweaking algorithm settings

• Enhanced user interface for comparing the results of different calibration optimization problems

Modeling Enhancements
• Improved integration of validation metrics within the model selection process
• Enhanced local modeling at each operating point (a complementary approach to building a single,

global model)
• Ability to alter variable ranges and refit models automatically
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Command-Line Interface to the Model-Based Calibration Toolbox
Software
The command-line interface to the Model-Based Calibration Toolbox software enables the modeling
process to be automated using MATLAB commands. In this way, you can simplify the modeling
process for technicians and engineers who might not have extensive background and training in this
area. You can also access modeling functionality from test bed automation tools.

Improved CAGE Setup
The CAGE Import Tool allows easier reusability of CAGE sessions. You can use the CAGE Import Tool
to import models, data sets, optimizations and features from any Model-Based Calibration Toolbox
project file produced in CAGE or the Model Browser (.mat or .cag). This feature can greatly simplify
the application of proven feature filling and optimization processes to new engine variants.

Optimization
Optimization in CAGE has had major updates:

• Significant speed improvements
• New optimization parameters that help avoid local minima by specifying multiple start points, and

running only from feasible start points
• Automatic scaling of objective and constraint values improves numerical stability of algorithms
• Enhanced table filling from optimization results now allows more flexible filling methods: you can

exclude infeasible solutions, choose whether to extrapolate, use selected solutions, and apply
custom fill algorithms

• Enhanced API for user-defined optimization scripts
• Improved results visualization for drive-cycle optimizations and multiobjective optimizations
• Improved constraint display for non-model constraints (1–D and 2–D tables, ellipsoid, etc.)

Compatibility Considerations
Some existing user-defined optimization scripts may require a call to the function
setRunInterfaceVersion to fix incompatibilities. You can also do this in the CAGE Browser GUI in
the Optimization Parameters dialog box.

If you want to use the new foptcon optimization parameters (multiple start points and run only from
feasible start points) with existing optimizations, you must use the menu item Optimization > Reset
Parameters.

Calibration Tool Interface
New links to standard industry tools allow import and export of calibrations directly from/to ATI
Vision (via a live link or .mat files) and ETAS INCA (via .dcm files).

Boundary Modeling
You can model boundaries using convex hulls. You can create boundary models for subsets of inputs,
which simplifies the boundary identification process for complex engines. Improved visualization tools
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in the Boundary Editor help you construct accurate constraints. Boundary constraints can now be
imported into the Design Editor and exported to Simulink.

Feature Filling
The Feature Fill Wizard uses new algorithms to fill and optimize table values with reference to a
model. You can fill multiple tables simultaneously using the wizard, extending the range of calibration
problems that CAGE can solve. You can impose gradient and smoothing penalties, and fill lookup
tables on a region-by-region basis.

Surface Viewer Movie
The Surface Viewer now has a movie mode that is faster and easier to use, with an interactive
progress bar.
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